关于海洋CMS使用外部采集器采集后图片不显示的解决办法

nelitse 8月前 1001

本帖最后由 nelitse 于 2018-9-22 01:38 编辑

关于海洋CMS使用外部采集器采集数据到网站后,

很多数据在前台显示不出图片的解决办法;

本人小白一枚,后面自己慢慢研究摸索这个问题要怎么处理,

想过一个数据一个数据的改,但发现原来采集回来的数据中,

图片文件都是包括有tu.php?tu=p.ssl.qhimg.com/t0122fb032140b59e7e.jpg类似字样的,

发现如果单独使用后面p.ssl.qhimg.com/t0122fb032140b59e7e.jpg这段的话是可以显示的,

只需要都把前面的tu.php?tu=批量删除掉就可以了,

然后刚好这时后台就有SQL高级助手,于是就使用了简单的SQL语句给处理了,

指定数据表ID值批量删除语句:

delete from sea_data where v_pic like '%tu.php?tu=%'


关于上次说的这段语句可以解决图片不显示问题,但实际操作后发现,这段语句是删除包含tu.php?tu=的所有表,导致采集回来的内容也一并删除了,但不影响数据库使用;

刚刚又找到了一段正确的代码,就是把表内包含有tu.php?tu=的替换成http://即可!

代码如下:

UPDATE `sea_data` SET `v_pic` = replace (`v_pic`,'tu.php?tu=','http://')


注:代码无情意识有价,在使用数据库语句命令时,请自行备份!!!
最新回复 (72)
  • cbjsw001 8月前
    0 引用 2
    我也遇到这个问题 该怎么解决
  • nelitse 8月前
    0 引用 3
    Quotecbjsw001 发表于 2018-9-20 22:09
    我也遇到这个问题 该怎么解决


    你清除包含tu.php?tu=的字段还显示不了吗?那你看下图片地址和路径是不是对的啊,对症下药;
  • 0 引用 4
    看看看看看看看看看看
  • 0 引用 5
    同意同意同意同意同意同意同意同意同意同意m
  • 0 引用 6
    关于海洋CMS使用外部采集器采集后图片不显示的解决办法
  • souloi 8月前
    0 引用 7
    关于海洋CMS使用外部采集器采集后图片不显示的解决办法
  • mxfcn 8月前
    0 引用 8
    看看解决办法。。
  • 0 引用 9
    谢谢分享
  • 游客 8月前
    0 引用 10
    谢谢分享
  • 游客 8月前
    0 引用 11
    查看一下是什么解决方案呢
  • aini8899 8月前
    0 引用 12
    看看解决办法,谢谢
  • wly2000 7月前
    0 引用 13
    很好,不错的帖子
  • vincent 7月前
    0 引用 14
    看看看看看看看看看看
  • anycin 7月前
    0 引用 15
    6666666666666666666666
  • 3581788 7月前
    0 引用 16
    看看看看!
  • 游客 7月前
    0 引用 17
    我也遇到这个问题 该怎么解决
  • cklige 6月前
    0 引用 18
    jk66666hlmvtiih
  • pjfan3 6月前
    0 引用 19
    很好,不错的帖子
  • 0 引用 20
    1111111111111111111111111
  • ralok 6月前
    0 引用 21
    这个可以下载下来吧
  • 游客 6月前
    0 引用 22
    看一下,我也是这样的
  • 游客 6月前
    0 引用 23
    看看~~~~~~~
  • 0 引用 24
    怎么解决
  • 0 引用 25
    究摸索这个问题要怎么处理,
  • JN598CVD 6月前
    0 引用 26
    个梵蒂冈电饭锅d
  • 0 引用 27
    海洋CMS使用外部采集器采集后图片不显示的解决办法
  • 游客 6月前
    0 引用 28
    我来看一下
  • fd9512 6月前
    0 引用 29

    看看解决办法
  • syc1991 6月前
    0 引用 30
    感谢楼主分享
  • 游客 6月前
    0 引用 31
    看看到底是因为什么
  • 游客 6月前
    0 引用 32
    来看看怎么搞!!
  • 游客 6月前
    0 引用 33
    我也遇到这个问题
  • 游客 6月前
    0 引用 34
    看看怎么解决的
  • 游客 6月前
    0 引用 35
    来看看
  • 游客 6月前
    0 引用 36
    求tu.php,我也遇到同样问题
  • wanghm 6月前
    0 引用 37
    1111111111111111111
  • 0 引用 38
    我也遇到这个问题 该怎么解决
  • opcop 6月前
    0 引用 39
    你清除包含tu.php?tu=的字段还显示不了吗?那你看下图片地址和路径是不是对的啊,对症下药;
  • 0 引用 40
    看看解决方案
  • 0 引用 41
    dsokgsdhjof
  • 游客 6月前
    0 引用 42
    可以的吗
  • 游客 5月前
    0 引用 43
    想做的不知道怎么观看解决
  • huayin 4月前
    0 引用 44
    有意思,支持
  • ynfrrx 4月前
    0 引用 45
    学习了,感谢分享!
  • admin511 4月前
    0 引用 46
    海洋CMS使用外部采集器采集后图片不显示的解决办法
  • djut89 4月前
    0 引用 47
    厉害
  • 0 引用 48
    安全科好:$
  • danran 4月前
    0 引用 49
    关于海洋CMS使用外部采集器采集后图片不显示的解决办法 [
  • 0 引用 50
    关于海洋CMS使用外部采集器采集后图片不显示
  • wusihao 3月前
    0 引用 51
    看看没注意a
  • wusihao 3月前
    0 引用 52
    看看没注意a 啊
  • 0 引用 53
    多谢楼主,正愁不知道怎么办呢
  • 0 引用 54
    不错不错哦
  • dream426 3月前
    0 引用 55
    海洋CMS使用外部采集器采集后图片不显示的解决办法
  • nnssn 3月前
    0 引用 56
    一直在找这个问题
  • aa2014 2月前
    0 引用 57
    看一下 试试行不行啊啊
  • elope 2月前
    0 引用 58
    看看找了好久都没有解决我的问题
  • zhoujan 2月前
    0 引用 59
    关于海洋CMS使用外部采集器采集后图片不显示的解决办法
  • 0 引用 60
    我也遇到图片莫名其妙不显示
  • 0 引用 61
    7777777777777777777
  • yvioy 2月前
    0 引用 62
    1111111111111111
  • panyi131 2月前
    0 引用 63
    uhvyugguiguig
  • 0 引用 64
    我也遇到这个问题 该怎么解决
  • 0 引用 65
    41dwadwa6dawdaw
  • qfjk 2月前
    0 引用 66
    我看看 学习一下~~
  • heima 2月前
    0 引用 67
    145654654454545
  • 0 引用 68
    我也遇到这个问题 该怎么解决
  • 可乐 2月前
    0 引用 69
    111111111111111111111111111
  • heheda 2月前
    0 引用 70
    学习学习学习学习学习
  • heyokj 2月前
    0 引用 71
    关于海洋CMS使用外部采集器采集后图片不显示的解决办法 [修
  • cnqing 1月前
    0 引用 72
    看看有没有用处
  • haiyyang 1月前
    0 引用 73
    995161098995161098995161098995161098995161098995161098995161098995161098995161098995161098995161098
  • 0 引用 74
    222222222222222222222222
  • walton 1月前
    0 引用 75
    希望有用
  • aini129 1月前
    0 引用 76
    fbhfgnfgnf
返回
发新帖